1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
3 # Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
4 # Contributor: William Rea <sillywilly@gmail.com>
9 pkgdesc="Read, write and manipulate GPS waypoints in a variety of formats"
11 url="https://www.gpsbabel.org/"
13 depends=(hicolor-icon-theme libusb shapelib qt6-serialport qt6-5compat)
14 makedepends=(cmake libicns qt6-tools)
15 source=(https://github.com/gpsbabel/$pkgname/archive/${pkgname}_${pkgver//./_}.tar.gz
17 sha256sums=('448379f0bf5f5e4514ed9ca8a1069b132f4d0e2ab350e2277e0166bf126b0832'
18 '5eb52ab0c4bdde61c747856e849f9bce9ca660e942c15f730a4330a38fd6a39a')
21 icns2png -x $pkgname-${pkgname}_${pkgver//./_}/gui/images/appicon.icns
25 cmake -B build -S $pkgname-${pkgname}_${pkgver//./_} \
26 -DCMAKE_INSTALL_PREFIX=/usr \
27 -DGPSBABEL_WITH_ZLIB=pkgconfig \
28 -DGPSBABEL_WITH_SHAPELIB=pkgconfig \
29 -DGPSBABEL_WITH_LIBUSB=pkgconfig \
30 -DGPSBABEL_MAPPREVIEW=OFF
35 DESTDIR="$pkgdir" cmake --install build
37 # make install is broken
38 install -Dm755 build/gpsbabel build/gui/GPSBabelFE/gpsbabelfe -t "$pkgdir"/usr/bin
39 install -Dm644 $pkgname-${pkgname}_${pkgver//./_}/gui/*.qm $pkgname-${pkgname}_${pkgver//./_}/gui/coretool/*.qm -t "$pkgdir"/usr/share/gpsbabel/translations
40 install -Dm644 $pkgname-${pkgname}_${pkgver//./_}/gui/gmapbase.html -t "$pkgdir"/usr/share/gpsbabel
41 install -Dm644 $pkgname-${pkgname}_${pkgver//./_}/gui/gpsbabel.desktop -t "$pkgdir"/usr/share/applications
42 install -Dm644 $pkgname.appdata.xml -t "$pkgdir/usr/share/metainfo"
44 for res in 16 32 128 256 512; do
45 install -Dm644 appicon_${res}x${res}x32.png \
46 "$pkgdir/usr/share/icons/hicolor/${res}x${res}/apps/$pkgname.png"