1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
2 # Contributor: Simon Parzer <simon.parzer@gmail.com>
8 pkgdesc='Pixelart-oriented painting program'
10 url='http://grafx2.chez.com/'
12 depends=(fontconfig hicolor-icon-theme lua sdl2_image sdl2_ttf)
15 source=("https://sourceforge.net/projects/recoil/files/recoil/$_recoilver/recoil-$_recoilver.tar.gz"
16 "git+https://gitlab.com/GrafX2/grafX2.git#commit=3fa8c98c17b01246c3d39acbeedf4b3db4de6654") # tag: v2.8
17 b2sums=('0748c0c6f795919af377b3718af482fe4c86b65b0370403d08bb60ad86b8ca78d43fe512410214e3ca8ed2bf46f68ee12c320efc26c3f256024c31c3e3dac205'
22 sed -i 's/-liconv//g' $pkgname/src/Makefile
24 # update the website URL
25 sed -i 's,2\.tk,2.chez.com,' $pkgname/misc/unix/grafx2.appdata.xml
27 # TODO: package recoil (retro computer image library) as a separate package
28 mkdir -p grafx2/3rdparty/archives
29 cp -u recoil-$_recoilver.tar.gz grafx2/3rdparty/archives/recoil-$_recoilver.tar.gz
33 make -C $pkgname/src API=sdl2 PREFIX=/usr
37 install -d "$pkgdir/usr/share/grafx2/scripts/samples_2.4/picture/"{thomson/lib,others-8bit/lib}
38 make -C $pkgname/src API=sdl2 DESTDIR="$pkgdir" PREFIX=/usr install
39 mv "$pkgdir/usr/bin/grafx2"{-sdl2,}
40 install -Dm644 $pkgname/doc/README.txt "$pkgdir/usr/share/doc/$pkgname/README"