upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / gtk-layer-shell / repos / community-x86_64 / PKGBUILD
blob0335e37637da9bb6849c8de111b7ab52dc706772
1 # Maintainer: Brett Cornwall <ainola@archlinux.org>
2 # Contributor: Adrian Perez de Castro <aperez@igalia.com>
4 pkgdesc='Library to create Wayland desktop components using the Layer Shell protocol'
5 pkgname=gtk-layer-shell
6 pkgver=0.8.1
7 pkgrel=1
8 arch=(x86_64)
9 license=(LGPL3)
10 url="https://github.com/wmww/gtk-layer-shell"
11 depends=(
12     "gtk3"
13     "wayland"
15 makedepends=(
16     "gtk-doc"
17     "gobject-introspection"
18     "meson"
19     "ninja"
20     "valabind"
22 source=("$pkgname-$pkgver.tar.gz::https://github.com/wmww/gtk-layer-shell/archive/v$pkgver.tar.gz")
23 sha512sums=('070673a73166c9fd0ea10e6aa98c480318fbf8a6c2dff2a9b4900aea40bb59680d41d9bba9917953fabe4358c0dfa6c3d0221c579ada37cee72ce23433b40329')
25 build() {
26     meson --prefix=/usr \
27           --wrap-mode=nofallback \
28           --buildtype=plain \
29           -Dtests=true \
30           -Ddocs=true \
31           -Dintrospection=true \
32           "$pkgname-$pkgver" \
33           build
34     ninja -C build
37 check() {
38     ninja -C build test
41 package() {
42     DESTDIR="$pkgdir" ninja -C build install