upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / guichan / trunk / PKGBUILD
blob83b2ef43d74e10326bbc53526731e6520987c4fe
1 # Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
2 # Contributor: Mateusz Herych <heniekk@gmail.com>
3 # Contributor: Bjørn Lindeijer <bjorn@lindeijer.nl>
5 pkgname=guichan
6 pkgver=0.8.2
7 pkgrel=7
8 pkgdesc="A portable C++ GUI library designed for games using Allegro, SDL and/or OpenGL."
9 arch=('x86_64')
10 url="http://guichan.sourceforge.net/"
11 license=('BSD')
12 depends=('gcc-libs')
13 makedepends=('sdl_image' 'allegro4' 'libgl' 'glut')
14 options=('!strip')
15 source=(https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/$pkgname/$pkgname-$pkgver.tar.gz)
16 sha256sums=('eedf206eae5201eaae027b133226d0793ab9a287bfd74c5f82c7681e3684eeab')
18 build() {
19   cd "${srcdir}"/$pkgname-$pkgver
21   CXXFLAGS="-g" ./configure --prefix=/usr
22   make
25 package() {
26   cd "${srcdir}"/$pkgname-$pkgver
28   make prefix="${pkgdir}"/usr install
30 # Install the license, as required for BSD
31   install -m644 -D COPYING "${pkgdir}"/usr/share/licenses/$pkgname/LICENSE