upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / hacksaw / repos / community-x86_64 / PKGBUILD
blob5665d51322fb64abc8ac4017c7ac5cb186243676
1 # Maintainer: Daniel M. Capella <polyzen@archlinux.org>
3 pkgname=hacksaw
4 pkgver=1.0.4
5 pkgrel=1
6 pkgdesc='Lightweight selection tool for usage in screenshot scripts etc.'
7 arch=('x86_64')
8 url=https://github.com/neXromancers/hacksaw
9 license=('MPL2')
10 depends=('gcc-libs' 'libxcb')
11 makedepends=('python' 'rust')
12 source=("hacksaw-$pkgver.tar.gz::https://static.crates.io/crates/hacksaw/hacksaw-$pkgver.crate")
13 sha512sums=('266cf94efa03a89a68d3d1f28fa9772b7815f0d4faf8126da757022624b174fc0246b5d576f1e767c2d7571a9c69725af8e28eec1a541d6f0ee5b3851a21147b')
15 build() {
16   cd hacksaw-$pkgver
17   cargo build --release --locked
20 package() {
21   cd hacksaw-$pkgver
22   install -Dt "$pkgdir"/usr/bin target/release/hacksaw
25 # vim:set ts=2 sw=2 et: