1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=haskell-arch-web
7 pkgdesc="Arch Linux official and AUR web interface binding"
8 url="https://github.com/berberman/arch-web"
11 depends=('ghc-libs' 'haskell-aeson' 'haskell-deriving-aeson' 'haskell-http-client'
12 'haskell-http-client-tls' 'haskell-http-types' 'haskell-lens' 'haskell-servant'
13 'haskell-servant-client' 'haskell-servant-client-core')
14 makedepends=('ghc' 'uusi' 'haskell-hunit')
15 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
16 sha256sums=('0d786f2f6da1f9b64e3c82838546152faf9c01f351cbb13b2bbb7f785a0d9de2')
20 uusi -u aeson -u lens -u servant $_hkgname.cabal
27 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
28 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
29 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
30 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
33 runhaskell Setup build $MAKEFLAGS
34 runhaskell Setup register --gen-script
35 runhaskell Setup unregister --gen-script
36 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
37 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
42 runhaskell Setup test --show-details=direct
48 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
49 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
50 runhaskell Setup copy --destdir="$pkgdir"
51 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
52 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE