upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-binary-orphans / repos / community-x86_64 / PKGBUILD
blob2146822ac8dae51132a6dc49bbcc7ac83cab929b
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=binary-orphans
5 pkgname=haskell-binary-orphans
6 pkgver=1.0.3
7 pkgrel=40
8 pkgdesc="Orphan instances for binary"
9 url="https://github.com/phadej/binary-orphans"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-onetuple')
13 makedepends=('ghc' 'uusi' 'haskell-quickcheck' 'haskell-quickcheck-instances' 'haskell-tasty'
14              'haskell-tasty-quickcheck' 'haskell-tagged')
15 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
16 sha512sums=('6c2cb933e4ff11b18bcbf9a7ab6274958a417b34ad9996df23468ecc37d41e7876611ec926363e12ca615f5aa50274d12f902ff4618eab254efafdfa0d5184a5')
18 prepare() {
19     cd $_hkgname-$pkgver
20     gen-setup
21     uusi -u tagged $_hkgname.cabal
24 build() {
25     cd $_hkgname-$pkgver
27     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
28         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
29         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
30     runhaskell Setup build $MAKEFLAGS
31     runhaskell Setup register --gen-script
32     runhaskell Setup unregister --gen-script
33     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
34     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
37 check() {
38     cd $_hkgname-$pkgver
39     runhaskell Setup test --show-details=direct
42 package() {
43     cd $_hkgname-$pkgver
45     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
46     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
47     runhaskell Setup copy --destdir="$pkgdir"
48     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
49     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE