upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-brick0.71 / trunk / PKGBUILD
blob600d67aba8c88482c1ff882e4bf14e77869768e4
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=brick
5 pkgname=haskell-brick0.71
6 pkgver=0.71.1
7 pkgrel=40
8 pkgdesc="A declarative terminal user interface library (legacy 0.71.* version)"
9 url="https://github.com/jtdaugherty/brick"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-vty' 'haskell-data-clist' 'haskell-dlist' 'haskell-microlens'
13          'haskell-microlens-th' 'haskell-microlens-mtl' 'haskell-config-ini' 'haskell-vector'
14          'haskell-contravariant' 'haskell-text-zipper' 'haskell-word-wrap')
15 makedepends=('ghc' 'haskell-quickcheck')
16 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
17 sha512sums=('f2fe3c32fe663e1c6d7688ebd058d792c5faf30a32997bbc45b828e2f10ec0c60720329a76b2035e05e28951a347602e0e751a125c8765c1f9d98696bd4b0564')
19 build() {
20     cd $_hkgname-$pkgver
22     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
23         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
24         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
25             -f-demos
26     runhaskell Setup build $MAKEFLAGS
27     runhaskell Setup register --gen-script
28     runhaskell Setup unregister --gen-script
29     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
33 check() {
34     cd $_hkgname-$pkgver
35     TERM=screen runhaskell Setup test --show-details=direct
38 package() {
39     cd $_hkgname-$pkgver
41     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
42     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
43     runhaskell Setup copy --destdir="$pkgdir"
44     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
45     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE