1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=containers-unicode-symbols
5 pkgname=haskell-containers-unicode-symbols
8 pkgdesc="Unicode alternatives for common functions and operators"
9 url="https://haskell.org/haskellwiki/Unicode-symbols"
12 depends=('ghc-libs' 'haskell-base-unicode-symbols')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('7294ebe2b85fddfac94d2d1e990722793d8d8e88ff1efb9d35394748ef5b05db132e42be3cce1d75b5f5b1ba97c6c2e75cb1f0b0d9c2e88dbed227094bfda5ea')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
24 runhaskell Setup build $MAKEFLAGS
25 runhaskell Setup register --gen-script
26 runhaskell Setup unregister --gen-script
27 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
28 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
34 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
35 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
36 runhaskell Setup copy --destdir="$pkgdir"
37 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
38 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE