upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-data-functor-logistic / repos / community-x86_64 / PKGBUILD
blob8b80d331641fc1e2216d6a080b3db989fb44ed45
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=data-functor-logistic
4 pkgname=haskell-data-functor-logistic
5 pkgver=0.0
6 pkgrel=16
7 pkgdesc="Updatable analogue of Distributive functors"
8 url="https://github.com/fumieval/data-functor-logistic"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-distributive')
12 makedepends=('ghc' 'uusi')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('15f794f13d4b0c7e7f89aa7c42fa7ff3cbb77a7a1a8168da8343e953af24594c')
16 prepare() {
17   cd $_hkgname-$pkgver
18   gen-setup
21 build() {
22   cd $_hkgname-$pkgver
24   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
27     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
28     --ghc-option='-pie' 
30   runhaskell Setup build $MAKEFLAGS
31   runhaskell Setup register --gen-script
32   runhaskell Setup unregister --gen-script
33   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
34   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
37 check() {
38   cd $_hkgname-$pkgver
39   runhaskell Setup test --show-details=direct
42 package() {
43   cd $_hkgname-$pkgver
45   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
46   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
47   runhaskell Setup copy --destdir="$pkgdir"