upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-double-conversion / trunk / PKGBUILD
blob3800d995c4379e287ec431cc17b2ecfde2175318
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=double-conversion
4 pkgname=haskell-double-conversion
5 pkgver=2.0.4.2
6 pkgrel=11
7 pkgdesc="Fast conversion between single and double precision floating point and text"
8 url="https://github.com/haskell/double-conversion"
9 license=('MIT')
10 arch=('x86_64')
11 depends=('ghc-libs' 'double-conversion')
12 makedepends=('ghc' 'haskell-hunit' 'haskell-test-framework' 'haskell-test-framework-hunit'
13              'haskell-test-framework-quickcheck2')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('00aaab567520813b80f603147ff2c745e0b01724f965e80c60bc6f8a13de9fd2288600afb8820c133600ddb69cee106a7b3d87dbd05871d094a886672e228267')
17 build() {
18     cd $_hkgname-$pkgver    
19     
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23             -f-embedded_double_conversion
24     runhaskell Setup build $MAKEFLAGS
25     runhaskell Setup register --gen-script
26     runhaskell Setup unregister --gen-script
27     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
28     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
31 check() {
32     cd $_hkgname-$pkgver
33     runhaskell Setup test --show-details=direct
36 package() {
37     cd $_hkgname-$pkgver
38     
39     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
40     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
41     runhaskell Setup copy --destdir="$pkgdir"
42     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
43     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE