upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-easy-file / trunk / PKGBUILD
blobafecd9e15933b850a0fd564620483ca8f208a067
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=easy-file
5 pkgname=haskell-easy-file
6 pkgver=0.2.3
7 pkgrel=2
8 pkgdesc="Cross-platform File handling"
9 url="https://github.com/kazu-yamamoto/easy-file"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs')
13 makedepends=('ghc' 'haskell-tasty' 'haskell-tasty-hunit')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('531652452c45b1ba9f21d14329402382a6a52f8211eb89141ea2b593104f324ac75c7c5d5e54b115f2d2a785ae6713ff40cc6214a47c3693b1bf5da1ac5c1dd5')
17 build() {
18     cd $_hkgname-$pkgver
19     
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 check() {
31     cd $_hkgname-$pkgver
32     runhaskell Setup test --show-details=direct
35 package() {
36     cd $_hkgname-$pkgver
37     
38     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
39     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
40     runhaskell Setup copy --destdir="$pkgdir"
41     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
42     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE