1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
7 pkgdesc="Conversion between emoji characters and their names"
8 url="https://github.com/jgm/emojis"
12 makedepends=('ghc' 'uusi' 'haskell-hunit')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('e34d1c1797f37e3cbe37f5f617496aa70310ca654c98069d393c10c5fcf56e336f35d06e018c859354ea54ae1c5fbbe4a24d484a5f59cceb5a9e3c25caf2a52d')
24 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
27 runhaskell Setup build $MAKEFLAGS
28 runhaskell Setup register --gen-script
29 runhaskell Setup unregister --gen-script
30 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 runhaskell Setup test --show-details=direct
42 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44 runhaskell Setup copy --destdir="$pkgdir"
45 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
46 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE