upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-erf / repos / community-x86_64 / PKGBUILD
blob2d8d426fbc1d825c31c81882443ef827d9b3b3cb
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=erf
5 pkgname=haskell-erf
6 pkgver=2.0.0.0
7 pkgrel=24
8 pkgdesc="The error function, erf, and related functions."
9 url="https://hackage.haskell.org/package/${_hkgname}"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs')
13 makedepends=('ghc')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('0803d78cbb4324c06174ec2162fb8408120acd7c644889fef51089de51c8165b075c6ea72d039e438ebf54ac5b8a0c0d6484077454e524fc1184cf82b778a0b1')
17 build() {
18     cd $_hkgname-$pkgver
19     
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 package() {
31     cd $_hkgname-$pkgver
32     
33     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
34     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
35     runhaskell Setup copy --destdir="$pkgdir"