upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-fclabels / repos / community-x86_64 / PKGBUILD
blobf869d90e353cc26c238b0628696534befebf4a0b
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=fclabels
5 pkgname=haskell-fclabels
6 pkgver=2.0.5.1
7 pkgrel=90
8 pkgdesc="First class accessor labels implemented as lenses."
9 url="https://github.com/sebastiaanvisser/fclabels"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-base-orphans')
13 makedepends=('ghc' 'haskell-hunit')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('a5f65a821e946381769bc98df2e78625820e99acf151886b9360e2327b589ac5bb2b214dd9cb27ac8e1e7d4880947771e2f020df69f3275d0310cd5fa293aa7b')
17 build() {
18     cd $_hkgname-$pkgver
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 check() {
31     cd $_hkgname-$pkgver
32     runhaskell Setup test --show-details=direct
35 package() {
36     cd $_hkgname-$pkgver
38     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
39     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
40     runhaskell Setup copy --destdir="$pkgdir"
41     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
42     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE