upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-filepath-bytestring / trunk / PKGBUILD
blobe60f377b28a85cdd95f94a06b8c6c9046fbd1e41
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=filepath-bytestring
4 pkgname=haskell-filepath-bytestring
5 pkgver=1.4.2.1.9
6 pkgrel=61
7 pkgdesc="Library for manipulating RawFilePaths in a cross platform way"
8 url="https://hackage.haskell.org/package/filepath-bytestring"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs')
12 makedepends=('ghc' 'haskell-quickcheck')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('814ca8e733afb85187055bf8fdf7381cba4de8587141eff678ec78aca76cd3042a40c3046d5fe4adaaa3575701c2a4172202ef9580ad66d87c92ee4a4e66fe87')
16 build() {
17     cd $_hkgname-$pkgver
19     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22     runhaskell Setup build $MAKEFLAGS
23     runhaskell Setup register --gen-script
24     runhaskell Setup unregister --gen-script
25     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
29 check() {
30     cd $_hkgname-$pkgver
31     runhaskell Setup test --show-details=direct
34 package() {
35     cd $_hkgname-$pkgver
37     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
38     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
39     runhaskell Setup copy --destdir="$pkgdir"
40     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
41     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE