upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-filepattern / trunk / PKGBUILD
blob9a666bff9728721241fee16a95cec0f7206477a2
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=filepattern
4 pkgname=haskell-filepattern
5 pkgver=0.1.3
6 pkgrel=43
7 pkgdesc="File path glob-like matching"
8 url="https://github.com/ndmitchell/filepattern"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-extra')
12 makedepends=('ghc' 'uusi' 'haskell-quickcheck')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('55abde992eeae3047e14ec66629bba807cff5554969e51c052c047761851d7d8afb8722fa733d673b67ab07aa014cdea3e4f2ff396e464a4f316cc2639904a44')
16 prepare() {
17   cd $_hkgname-$pkgver
18   gen-setup
21 build() {
22     cd $_hkgname-$pkgver    
23     
24     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
27     runhaskell Setup build $MAKEFLAGS
28     runhaskell Setup register --gen-script
29     runhaskell Setup unregister --gen-script
30     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
34 check() {
35     cd $_hkgname-$pkgver
36     runhaskell Setup test --show-details=direct
39 package() {
40     cd $_hkgname-$pkgver
41     
42     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44     runhaskell Setup copy --destdir="$pkgdir"
45     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
46     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE