upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-ghc-typelits-extra / trunk / PKGBUILD
blob0876c8ea85db393276f2326b1cb8d2b85a8a6e7b
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=ghc-typelits-extra
4 pkgname=haskell-ghc-typelits-extra
5 pkgver=0.4.4
6 pkgrel=10
7 pkgdesc="Additional type-level operations on GHC.TypeLits.Nat"
8 url="https://github.com/clash-lang/ghc-typelits-extra"
9 license=('custom:BSD2')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-ghc' 'haskell-ghc-tcplugins-extra' 'haskell-ghc-typelits-knownnat'
12          'haskell-ghc-typelits-natnormalise')
13 makedepends=('ghc' 'haskell-tasty' 'haskell-tasty-hunit')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('bdb439dcfe5f844ac6107e26c929d9c4769e4c6a7e9c10c3e57f52fa43c6ca32d97bc1aa7810d95010877169c1bffa320bb3ef47993f6eb26a59b877ac0b0921')
17 build() {
18     cd $_hkgname-$pkgver
19     
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 check() {
31     cd $_hkgname-$pkgver
32     runhaskell Setup test --show-details=direct
35 package() {
36     cd $_hkgname-$pkgver
37     
38     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
39     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
40     runhaskell Setup copy --destdir="$pkgdir"
41     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
42     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE