1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
8 url="https://github.com/haskell-gi/haskell-gi"
11 depends=('ghc-libs' 'haskell-gi-cairo' 'haskell-gi-gdkpixbuf' 'haskell-gi-gio' 'haskell-gi-glib'
12 'haskell-gi-gobject' 'haskell-gi-pango' 'haskell-gi' 'haskell-gi-base'
13 'haskell-gi-overloading' 'gtk4')
14 makedepends=('ghc' 'gobject-introspection')
15 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
16 sha256sums=('5d410380861e4e9ec585c67d3a800f30a9c7980e84e49e561eb88791eada48dd')
21 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
22 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
23 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
24 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
27 runhaskell Setup build $MAKEFLAGS
28 runhaskell Setup register --gen-script
29 runhaskell Setup unregister --gen-script
30 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 runhaskell Setup test --show-details=direct
42 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44 runhaskell Setup copy --destdir="$pkgdir"
45 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
46 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE