upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-hakyll / trunk / PKGBUILD
blob0bee5df276ea35bff22cb06d43c2c4fdd34c70f8
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Caleb Maclennan <caleb@alerque.com>
3 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
5 _hkgname=hakyll
6 pkgname=haskell-hakyll
7 pkgver=4.15.1.1
8 pkgrel=265
9 pkgdesc="A static website compiler library"
10 url="https://jaspervdj.be/hakyll"
11 license=("BSD")
12 arch=('x86_64')
13 depends=('ghc-libs' 'haskell-aeson' 'haskell-blaze-html' 'haskell-blaze-markup'
14          'haskell-data-default' 'haskell-file-embed' 'haskell-fsnotify' 'haskell-hashable'
15          'haskell-http-conduit' 'haskell-http-types' 'haskell-lifted-async' 'haskell-lrucache'
16          'haskell-network-uri' 'haskell-optparse-applicative' 'haskell-pandoc' 'haskell-random'
17          'haskell-regex-tdfa' 'haskell-resourcet' 'haskell-scientific' 'haskell-tagsoup'
18          'haskell-time-locale-compat' 'haskell-unordered-containers' 'haskell-vector' 'haskell-wai'
19          'haskell-wai-app-static' 'haskell-warp' 'haskell-yaml')
20 makedepends=('ghc' 'uusi' 'haskell-quickcheck' 'haskell-tasty' 'haskell-tasty-golden' 'haskell-tasty-hunit'
21              'haskell-tasty-quickcheck')
22 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz"
23         $pkgname-pandoc-3.0.patch::https://github.com/jaspervdj/hakyll/commit/2ea5d682cfb7631bc00c9452e5fdc1c1c15900f8.patch)
24 sha512sums=('c0fee6bedfe19677484e41d2d0a098bf351c35a8b3adc7fe5de407a0686dd1d1108584b05525f70ce7cac94919b50c09be91706226bbc3f3e3d155cc9bc1eb34'
25             'eacfeb136de91a27b8b9d47449dbfe2af5ea688f4d3cf6e739a16cddcf89c5da4272ca58ed1dab079ad627e9440acf58dec3f1d84eacb7121041c3c31e1aa699')
27 prepare() {
28     cd $_hkgname-$pkgver
29     patch -p1 -i ../$pkgname-pandoc-3.0.patch || : # ignore patch failures on cabal file
30     uusi -u aeson -u fsnotify -u optparse-applicative -u pandoc -u vector $_hkgname.cabal
33 build() {
34     cd $_hkgname-$pkgver
36     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
37         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
38         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
39             -fcheckexternal -fwatchserver -fpreviewserver -fusepandoc
40     runhaskell Setup build $MAKEFLAGS
41     runhaskell Setup register --gen-script
42     runhaskell Setup unregister --gen-script
43     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
44     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
47 check() {
48     cd $_hkgname-$pkgver
49     LC_CTYPE=en_US.UTF-8 runhaskell Setup test --show-details=direct
52 package() {
53     cd $_hkgname-$pkgver
55     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
56     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
57     runhaskell Setup copy --destdir="$pkgdir"
58     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
59     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE