1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=hls-retrie-plugin
4 pkgname=haskell-hls-retrie-plugin
7 pkgdesc="Retrie integration plugin for Haskell Language Server"
8 url="https://hackage.haskell.org/package/hls-retrie-plugin"
11 depends=('ghc-libs' 'haskell-aeson' 'haskell-extra' 'haskell-ghc' 'haskell-ghcide'
12 'haskell-hashable' 'haskell-hls-plugin-api' 'haskell-lsp' 'haskell-lsp-types'
13 'haskell-retrie' 'haskell-safe-exceptions' 'haskell-unordered-containers')
14 makedepends=('ghc' 'uusi')
15 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
16 sha512sums=('0a2fbd1e3dd52b7db1b1f0b3c58e8a9a3c749bcb57a8f5f4819183f1f6bc2d07fa27fa73351cd945d70683c3e6204c7dfea6e036a9b0c06a64ceb00dd94587b3')
26 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
27 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
28 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
29 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
32 runhaskell Setup build $MAKEFLAGS
33 runhaskell Setup register --gen-script
34 runhaskell Setup unregister --gen-script
35 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
36 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
41 runhaskell Setup test --show-details=direct
47 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
48 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
49 runhaskell Setup copy --destdir="$pkgdir"
50 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
51 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE