1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=haskell-hslua-aeson
7 pkgdesc="Allow aeson data types to be used with Lua."
8 url="https://hslua.org/"
11 depends=('ghc-libs' 'haskell-aeson' 'haskell-hashable' 'haskell-hslua-core'
12 'haskell-hslua-marshalling' 'haskell-scientific' 'haskell-unordered-containers'
14 makedepends=('ghc' 'uusi' 'haskell-quickcheck' 'haskell-quickcheck-instances' 'haskell-tasty'
15 'haskell-tasty-quickcheck')
16 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
17 sha256sums=('ab221cf59b915fba43deed51514a3703f7b0e504a2e26c6c787cb855bc9af545')
27 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
28 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
29 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
30 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
33 runhaskell Setup build $MAKEFLAGS
34 runhaskell Setup register --gen-script
35 runhaskell Setup unregister --gen-script
36 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
37 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
42 runhaskell Setup test --show-details=direct
48 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
49 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
50 runhaskell Setup copy --destdir="$pkgdir"
51 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
52 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE