upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-hslua-aeson / trunk / PKGBUILD
blob9b7d55e9d44461369b43aef486407789ce0e0eb4
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=hslua-aeson
4 pkgname=haskell-hslua-aeson
5 pkgver=2.2.1
6 pkgrel=44
7 pkgdesc="Allow aeson data types to be used with Lua."
8 url="https://hslua.org/"
9 license=("MIT")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-aeson' 'haskell-hashable' 'haskell-hslua-core'
12          'haskell-hslua-marshalling' 'haskell-scientific' 'haskell-unordered-containers'
13          'haskell-vector')
14 makedepends=('ghc' 'uusi' 'haskell-quickcheck' 'haskell-quickcheck-instances' 'haskell-tasty'
15              'haskell-tasty-quickcheck')
16 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
17 sha256sums=('ab221cf59b915fba43deed51514a3703f7b0e504a2e26c6c787cb855bc9af545')
19 prepare() {
20   cd $_hkgname-$pkgver
21   gen-setup
24 build() {
25   cd $_hkgname-$pkgver
27   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
28     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
29     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
30     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
31     --ghc-option='-pie'
33   runhaskell Setup build $MAKEFLAGS
34   runhaskell Setup register --gen-script
35   runhaskell Setup unregister --gen-script
36   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
37   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
40 check() {
41   cd $_hkgname-$pkgver
42   runhaskell Setup test --show-details=direct
45 package() {
46   cd $_hkgname-$pkgver
48   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
49   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
50   runhaskell Setup copy --destdir="$pkgdir"
51   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
52   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE