1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=hslua-module-text
5 pkgname=haskell-hslua-module-text
8 pkgdesc="Lua module for text"
9 url="https://github.com/hslua/hslua-module-text"
12 depends=('ghc-libs' 'haskell-hslua-core' 'haskell-hslua-marshalling' 'haskell-hslua-packaging')
13 makedepends=('ghc' 'haskell-tasty' 'haskell-tasty-hunit' 'haskell-tasty-lua')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('1252d80ce2b6a5fca52b5d4b71bedaa7a95be6bf3cb62cde33073aebc446070b4fe6227f0b637f82d1d022d5243987e55ff27eb01ee73e230efb3c033bfa6dfa')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23 runhaskell Setup build $MAKEFLAGS
24 runhaskell Setup register --gen-script
25 runhaskell Setup unregister --gen-script
26 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 runhaskell Setup test --show-details=direct
38 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
39 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
40 runhaskell Setup copy --destdir="$pkgdir"
41 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
42 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE