upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-indexed-traversable-instances / trunk / PKGBUILD
blobc8d1a59550de1e09e894794efd807df4c4a0cebd
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=indexed-traversable-instances
4 pkgname=haskell-indexed-traversable-instances
5 pkgver=0.1.1.1
6 pkgrel=45
7 pkgdesc="More instances of FunctorWithIndex, FoldableWithIndex, TraversableWithIndex"
8 url="https://github.com/haskellari/indexed-traversable"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-indexed-traversable' 'haskell-onetuple' 'haskell-tagged'
12          'haskell-unordered-containers' 'haskell-vector')
13 makedepends=('ghc' 'uusi' 'haskell-quickcheck' 'haskell-quickcheck-instances' 'haskell-tasty'
14              'haskell-tasty-quickcheck')
15 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
16 sha256sums=('895ee5063d59e2b58930ca6fa54885bb11f19c8b7c7ba6c7b014f9431cdcc0b0')
18 prepare() {
19   cd $_hkgname-$pkgver
20   gen-setup
23 build() {
24   cd $_hkgname-$pkgver
26   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
27     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
28     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
29     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
30     --ghc-option='-pie'
32   runhaskell Setup build $MAKEFLAGS
33   runhaskell Setup register --gen-script
34   runhaskell Setup unregister --gen-script
35   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
36   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
39 check() {
40   cd $_hkgname-$pkgver
41   runhaskell Setup test --show-details=direct
44 package() {
45   cd $_hkgname-$pkgver
47   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
48   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
49   runhaskell Setup copy --destdir="$pkgdir"
50   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
51   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE