upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-ipynb / trunk / PKGBUILD
blob68ef4af964dabfb28499e0a2f617c4a71f0dcdcd
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=ipynb
4 pkgname=haskell-ipynb
5 pkgver=0.2
6 pkgrel=89
7 pkgdesc="Data structure for working with Jupyter notebooks (ipynb)"
8 url="https://github.com/jgm/ipynb"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-aeson' 'haskell-base64-bytestring' 'haskell-unordered-containers')
12 makedepends=('ghc' 'haskell-microlens' 'haskell-microlens-aeson' 'haskell-tasty'
13              'haskell-tasty-hunit')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('885ffa2f2269b2bc6c2381fe7a7c91de93e8539ca3493d5a8207e75e986fc42a4b8ead0b4d05184da5bbb931466431ca1b810f03db8cd2c1624a67e1bbb782ea')
17 build() {
18     cd $_hkgname-$pkgver
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 check() {
31     cd $_hkgname-$pkgver
32     runhaskell Setup test --show-details=direct
35 package() {
36     cd $_hkgname-$pkgver
38     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
39     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
40     runhaskell Setup copy --destdir="$pkgdir"
41     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
42     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE