1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
7 pkgdesc="Access to platform dependent file locking APIs"
8 url="https://github.com/phadej/lukko"
12 makedepends=('ghc' 'uusi' 'haskell-async' 'haskell-singleton-bool' 'haskell-tasty'
13 'haskell-tasty-expected-failure' 'haskell-tasty-hunit' 'haskell-temporary')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('8bed8b88a101883f642bb9d9d41512436f5c80db5ea1ad0cddb069c6d09257d21b56a60e0f70b57453e91126065fbfdeeb721064763e64de1975dcb51b1a484a')
19 uusi -u base $_hkgname.cabal
25 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
28 runhaskell Setup build $MAKEFLAGS
29 runhaskell Setup register --gen-script
30 runhaskell Setup unregister --gen-script
31 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
32 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
37 runhaskell Setup test --show-details=direct
43 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
44 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
45 runhaskell Setup copy --destdir="$pkgdir"
46 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
47 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE