upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-monad-logger / trunk / PKGBUILD
blobd00c31e8e23ceee0ada1f7359851c1f9d36883af
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=monad-logger
5 pkgname=haskell-monad-logger
6 pkgver=0.3.39
7 pkgrel=27
8 pkgdesc="A class of monads which can log messages."
9 url="https://github.com/snoyberg/monad-logger"
10 license=("MIT")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-conduit' 'haskell-conduit-extra'
13          'haskell-fast-logger' 'haskell-lifted-base' 'haskell-monad-control' 'haskell-monad-loops'
14          'haskell-resourcet' 'haskell-stm-chans'
15          'haskell-transformers-base' 'haskell-transformers-compat' 'haskell-unliftio-core')
16 makedepends=('ghc')
17 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
18 sha512sums=('2f353ff26f121ef9e89d033a6ab9a240422aab91e6cbc8112d81d52b217c24deb6800c2c641e417ac430ff791666bd0e676bcea4aa7cbdb22df167f2d51364d4')
20 build() {
21     cd $_hkgname-$pkgver
23     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
24         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
25         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
26             -ftemplate_haskell
27     runhaskell Setup build $MAKEFLAGS
28     runhaskell Setup register --gen-script
29     runhaskell Setup unregister --gen-script
30     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
34 check() {
35     cd $_hkgname-$pkgver
36     runhaskell Setup test --show-details=direct
39 package() {
40     cd $_hkgname-$pkgver
42     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44     runhaskell Setup copy --destdir="$pkgdir"
45     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
46     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE