upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-nanospec / trunk / PKGBUILD
blob6b483faf75cf96faccbc55f0f9a1fe9c8baac983
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=nanospec
4 pkgname=haskell-nanospec
5 pkgver=0.2.2
6 pkgrel=322
7 pkgdesc="A lightweight implementation of a subset of Hspec's API"
8 url="https://github.com/commercialhaskell/nanospec"
9 license=('MIT')
10 arch=('x86_64')
11 depends=('ghc-libs')
12 makedepends=('ghc')
13 checkdepends=('haskell-hspec' 'haskell-silently')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('6161b5cc1797a3fdcd07cad14deaa3edd6faa87309b5e8a31834d7c1dda23737fe4f2e763b13da7f5ef6f6ee3a9414f88b9ae01e5403320ba23d76404324a3b0')
17 build() {
18     cd $_hkgname-$pkgver
20     if (( CHECKFUNC )); then
21         _opts=('--enable-tests')
22     else
23         _opts=('--disable-tests')
24     fi
26     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
27         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname "${_opts[@]}" \
28         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
29     runhaskell Setup build $MAKEFLAGS
30     runhaskell Setup register --gen-script
31     runhaskell Setup unregister --gen-script
32     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
33     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 check() {
37     cd $_hkgname-$pkgver
38     runhaskell Setup test --show-details=direct
41 package() {
42     cd $_hkgname-$pkgver
43     
44     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
45     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
46     runhaskell Setup copy --destdir="$pkgdir"
47     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
48     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE