upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-options / trunk / PKGBUILD
blob9f540140b06a5785d278ee7fb602cd43fe2a5cc5
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=options
4 pkgname=haskell-options
5 pkgver=1.2.1.1
6 pkgrel=19
7 pkgdesc="A powerful and easy-to-use command-line option parser"
8 url="https://john-millikin.com/software/haskell-options/"
9 license=('MIT')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-monads-tf')
12 makedepends=('ghc')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('615a3767b74ca0ba2eae993f6e475963df2a0933f1e6c9bbfe35144c4dc6018af276144b2ec1b608b695dc7fca904784ebc63cd58a432f966588846cb36f94ea')
16 build() {
17     cd $_hkgname-$pkgver
18     
19     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20         --prefix=/usr --docdir=/usr/share/doc/$pkgname \
21         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22     runhaskell Setup build $MAKEFLAGS
23     runhaskell Setup register --gen-script
24     runhaskell Setup unregister --gen-script
25     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
29 # Tests not enabled due to circular dependency on chell
31 package() {
32     cd $_hkgname-$pkgver
33     
34     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
35     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
36     runhaskell Setup copy --destdir="$pkgdir"
37     install -D -m644 "license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
38     rm -f "${pkgdir}/usr/share/doc/${pkgname}/license.txt"