upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-pcre-light / trunk / PKGBUILD
blobe6518f30d10ef37287cd21bce3e209fd332780ba
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=pcre-light
5 pkgname=haskell-pcre-light
6 pkgver=0.4.1.0
7 pkgrel=242
8 pkgdesc="Portable regex library for Perl 5 compatible regular expressions"
9 url="https://github.com/Daniel-Diaz/pcre-light"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' 'pcre')
13 makedepends=('ghc')
14 checkdepends=('haskell-hunit')
15 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
16 sha512sums=('491d9581e4c29d1a5a3b161210b83abbc135c2d0ee4018481f4101f91c95e93d7acf0764cb464a9ffe84bed9bf8fb400f4c68441ae1be03c0aa182a9be26dc39')
18 build() {
19     cd $_hkgname-$pkgver
20     
21     if (( CHECKFUNC )); then
22         _opts=('--enable-tests')
23     else
24         _opts=('--disable-tests')
25     fi
27     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
28         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname "${_opts[@]}" \
29         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
30             -f-old_base -fuse-pkg-config
31     runhaskell Setup build $MAKEFLAGS
32     runhaskell Setup register --gen-script
33     runhaskell Setup unregister --gen-script
34     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
35     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
38 check() {
39     cd $_hkgname-$pkgver
40     runhaskell Setup test --show-details=direct
43 package() {
44     cd $_hkgname-$pkgver
45     
46     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
47     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
48     runhaskell Setup copy --destdir="$pkgdir"
49     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
50     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE