upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-pid1 / trunk / PKGBUILD
blobe73cac12876688c13c25e84814131fd7fd63a07f
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Thomas Dziedzic <gostrc@gmail.com>
4 _hkgname=pid1
5 pkgname=haskell-pid1
6 pkgver=0.1.3.1
7 pkgrel=1
8 pkgdesc="Do signal handling and orphan reaping for Unix PID1 init processes"
9 url="https://github.com/fpco/pid1"
10 license=('MIT')
11 arch=('x86_64')
12 depends=('ghc-libs')
13 makedepends=('ghc')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('f52f5e1fde47403c0bdf394f9502e104c826ff8bac52449f0424a11375ce55797ec19e2abd551fca58cf9a4280480b7199f4a02d45b97fe21f55e56e40da018a')
17 build() {
18     cd $_hkgname-$pkgver
19     
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 package() {
31     cd $_hkgname-$pkgver
32     
33     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
34     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
35     runhaskell Setup copy --destdir="$pkgdir"
36     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
37     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE