upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-postgresql-libpq / trunk / PKGBUILD
blob7ca34bd24438c8fdfd6c2e16bf7eb21e5adf2139
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=postgresql-libpq
5 pkgname=haskell-postgresql-libpq
6 pkgver=0.9.4.3
7 pkgrel=6
8 pkgdesc="Low-level binding to libpq"
9 url="https://github.com/phadej/postgresql-libpq"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' "postgresql-libs")
13 makedepends=('ghc' 'uusi')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('2a600ebc694fde0bd1bb9760113ce9c7dcbad1a447c46356b1174ee7a76e910955c265a2ace5e687eb36f11a57a4ec832178706fa878695cc848df3dc9833562')
17 prepare() {
18     cd $_hkgname-$pkgver
19     uusi -u base $_hkgname.cabal
22 build() {
23     cd $_hkgname-$pkgver
24     
25     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26         --prefix=/usr --docdir=/usr/share/doc/$pkgname \
27         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
28             -f-use-pkg-config
29     runhaskell Setup build $MAKEFLAGS
30     runhaskell Setup register --gen-script
31     runhaskell Setup unregister --gen-script
32     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
33     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 package() {
37     cd $_hkgname-$pkgver
38     
39     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
40     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
41     runhaskell Setup copy --destdir="$pkgdir"
42     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
43     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE