upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-prim-uniq / repos / community-x86_64 / PKGBUILD
blob98ec228124d1ed91e14833faad78120a83e9c8a5
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=prim-uniq
4 pkgname=haskell-prim-uniq
5 pkgver=0.2
6 pkgrel=56
7 pkgdesc="Opaque unique identifiers in primitive state monads"
8 url="https://github.com/obsidiansystems/prim-uniq"
9 license=("custom:PublicDomain")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-dependent-sum' 'haskell-primitive')
12 makedepends=('ghc')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('bbadfebdc4def5cc8a9db3458df710c45f2b4e72ee5d2e6c42562b77c7a6f2d0')
16 build() {
17   cd $_hkgname-$pkgver
19   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
23     --ghc-option='-pie' 
25   runhaskell Setup build $MAKEFLAGS
26   runhaskell Setup register --gen-script
27   runhaskell Setup unregister --gen-script
28   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 check() {
33   cd $_hkgname-$pkgver
34   runhaskell Setup test --show-details=direct
37 package() {
38   cd $_hkgname-$pkgver
40   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
41   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
42   runhaskell Setup copy --destdir="$pkgdir"