upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-ptr / trunk / PKGBUILD
blobba7b6b1eccc45a93e95e7a4175d13bb498ab0b4e
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=ptr
4 pkgname=haskell-ptr
5 pkgver=0.16.8.4
6 pkgrel=34
7 pkgdesc="Experimental abstractions for operations on pointers"
8 url="https://github.com/nikita-volkov/ptr"
9 license=("MIT")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-contravariant' 'haskell-profunctors' 'haskell-strict-list'
12          'haskell-vector')
13 makedepends=('ghc' 'uusi' 'haskell-quickcheck' 'haskell-cereal' 'haskell-quickcheck-instances'
14              'haskell-rerebase' 'haskell-tasty' 'haskell-tasty-hunit' 'haskell-tasty-quickcheck')
15 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
16 sha256sums=('902efd4a9aa266eea3320f4747f72abd0763a9156200f5c845c1c39a9024ee10')
18 prepare() {
19   cd $_hkgname-$pkgver
20   gen-setup
23 build() {
24   cd $_hkgname-$pkgver
26   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
27     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
28     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
29     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
30     --ghc-option='-pie'
32   runhaskell Setup build $MAKEFLAGS
33   runhaskell Setup register --gen-script
34   runhaskell Setup unregister --gen-script
35   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
36   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
39 check() {
40   cd $_hkgname-$pkgver
41   runhaskell Setup test --show-details=direct
44 package() {
45   cd $_hkgname-$pkgver
47   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
48   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
49   runhaskell Setup copy --destdir="$pkgdir"
50   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
51   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE