1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
5 pkgname=haskell-resource-pool
8 pkgdesc="A high-performance striped resource pooling implementation"
9 url="https://github.com/bos/pool"
12 depends=('ghc-libs' "haskell-hashable" "haskell-monad-control"
13 "haskell-transformers-base" "haskell-vector")
15 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
16 sha512sums=('42b0bb6dea35c08884f65604acc0dd93707b8d4de780c584877e92fbfe534d4f754282e9c9f7257c203f1152d85ac8170f84ee9a95573343d02a774006c4118b')
21 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
22 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
23 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
25 runhaskell Setup build $MAKEFLAGS
26 runhaskell Setup register --gen-script
27 runhaskell Setup unregister --gen-script
28 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
35 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
36 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
37 runhaskell Setup copy --destdir="$pkgdir"
38 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
39 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE