1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=should-not-typecheck
4 pkgname=haskell-should-not-typecheck
7 pkgdesc="A HUnit/hspec assertion library to verify that an expression does not typecheck"
8 url="https://github.com/CRogers/should-not-typecheck"
11 depends=('ghc-libs' 'haskell-hunit')
12 makedepends=('ghc' 'haskell-hspec' 'haskell-hspec-expectations')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('46ba4435a4408e23dfe6e04f827a7efcfd3c94a4a53a0562061d5cd40c11fcbae7569e695329fe98f9d9ecea1999ac68da6594d2ca60c2efccdac2d6d674d65d')
19 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22 runhaskell Setup build $MAKEFLAGS
23 runhaskell Setup register --gen-script
24 runhaskell Setup unregister --gen-script
25 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
31 runhaskell Setup test --show-details=direct
37 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
38 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
39 runhaskell Setup copy --destdir="$pkgdir"
40 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
41 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE