upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-tasty-checklist / trunk / PKGBUILD
blobb7b0a3225513ef9a1ecc58554071e48a07fff904
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=tasty-checklist
4 pkgname=haskell-tasty-checklist
5 pkgver=1.0.5.1
6 pkgrel=2
7 pkgdesc="Check multiple items during a tasty test"
8 url="https://github.com/kquick/tasty-checklist"
9 license=("custom:ISC")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-parameterized-utils')
12 makedepends=('ghc' 'uusi' 'haskell-doctest' 'haskell-hunit' 'haskell-tasty'
13              'haskell-tasty-expected-failure' 'haskell-tasty-hunit')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha512sums=('d688ace3d3239b4279f9fdb85c8fc9af4d8edb3b5024fcc6eb3518a151a9830e3bec8c8820f190e64ebd95b0690739883eeee81fa926fbdd3a3dfeab4dc72ccf')
17 prepare() {
18   cd $_hkgname-$pkgver
19   gen-setup
22 build() {
23   cd $_hkgname-$pkgver
25   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
28     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
29     --ghc-option='-pie'
31   runhaskell Setup build $MAKEFLAGS
32   runhaskell Setup register --gen-script
33   runhaskell Setup unregister --gen-script
34   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
35   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
38 check() {
39   cd $_hkgname-$pkgver
40   runhaskell Setup test --show-details=direct
43 package() {
44   cd $_hkgname-$pkgver
46   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
47   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
48   runhaskell Setup copy --destdir="$pkgdir"