upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-tasty-hspec / repos / community-x86_64 / PKGBUILD
blob17359113565c6bce59ef150e8fe79a1037d9cbc0
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=tasty-hspec
4 pkgname=haskell-tasty-hspec
5 pkgver=1.2.0.3
6 pkgrel=5
7 pkgdesc="Hspec support for the Tasty test framework"
8 url="https://github.com/mitchellwrosen/tasty-hspec"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-hspec' 'haskell-hspec-core' 'haskell-quickcheck' 'haskell-tasty'
12          'haskell-tasty-smallcheck' 'haskell-tasty-quickcheck')
13 makedepends=('ghc')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('7b1c23a3ad2f3392fa0200bcf193a2c6c743f1729208e308173ab4b11c4b5358aaf5146eff8a37a25934d7b2d01847a7de4e82fb0b642cc57a9fc46f373f77b3')
17 build() {
18     cd $_hkgname-$pkgver
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 check() {
31     cd $_hkgname-$pkgver
32     runhaskell Setup test --show-details=direct
35 package() {
36     cd $_hkgname-$pkgver
38     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
39     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
40     runhaskell Setup copy --destdir="$pkgdir"
41     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
42     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE