1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=text-builder-dev
4 pkgname=haskell-text-builder-dev
7 pkgdesc='Edge of developments for "text-builder"'
8 url="https://github.com/nikita-volkov/text-builder-dev"
11 depends=('ghc-libs' 'haskell-deferred-folds' 'haskell-isomorphism-class' 'haskell-split')
12 makedepends=('ghc' 'uusi' 'haskell-quickcheck' 'haskell-quickcheck-instances' 'haskell-rerebase'
13 'haskell-tasty' 'haskell-tasty-hunit' 'haskell-tasty-quickcheck')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('f574e2219a44ba4c14ee9d373f59bee3ed9a3863082468d97bff5621a82755af')
25 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
28 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
31 runhaskell Setup build $MAKEFLAGS
32 runhaskell Setup register --gen-script
33 runhaskell Setup unregister --gen-script
34 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
35 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
40 runhaskell Setup test --show-details=direct
46 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
47 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
48 runhaskell Setup copy --destdir="$pkgdir"
49 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
50 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE