upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-tls-session-manager / repos / community-x86_64 / PKGBUILD
blobc4b22179f107736ca10aaa553e3700c028556e6f
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=tls-session-manager
5 pkgname=haskell-tls-session-manager
6 pkgver=0.0.4
7 pkgrel=321
8 pkgdesc="In-memory TLS session manager"
9 url="https://hackage.haskell.org/package/tls-session-manager"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' "haskell-auto-update" 'haskell-basement' "haskell-clock" 'haskell-memory'
13          "haskell-psqueues" "haskell-tls")
14 makedepends=('ghc')
15 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
16 sha512sums=('8516a2a6a12ee33ca3cbfcf33f5108218dcfea54b092a5292cbe0935b1c181d1aa26d171eb1f62d93ac80bebca21221598a07e225be5513743b227ef6908fbec')
18 build() {
19     cd $_hkgname-$pkgver
21     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
22         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
23         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
24     runhaskell Setup build $MAKEFLAGS
25     runhaskell Setup register --gen-script
26     runhaskell Setup unregister --gen-script
27     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
28     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
31 package() {
32     cd $_hkgname-$pkgver
34     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
35     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
36     runhaskell Setup copy --destdir="$pkgdir"
37     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
38     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE