1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=type-errors-pretty
4 pkgname=haskell-type-errors-pretty
7 pkgdesc="Combinators for writing pretty type errors easily"
8 url="https://github.com/kowainik/type-errors-pretty"
12 makedepends=('ghc' 'uusi' 'haskell-doctest' 'haskell-glob')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('d36c06660d0088dbc5e63ba43ae0af5563335844002294a09da2da9936d8df545c6b9a11015fcc1416b1e06ba3fc4fd60cc5a47cbe481368643e01122d7f4740')
19 uusi -u doctest $_hkgname.cabal
25 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
28 runhaskell Setup build $MAKEFLAGS
29 runhaskell Setup register --gen-script
30 runhaskell Setup unregister --gen-script
31 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
32 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
37 runhaskell Setup test --show-details=direct
43 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
44 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
45 runhaskell Setup copy --destdir="$pkgdir"
46 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
47 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE