1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=haskell-unagi-chan
7 pkgdesc="Fast concurrent queues with a Chan-like API, and more"
8 url="https://github.com/jberryman/unagi-chan"
11 depends=('ghc-libs' 'haskell-atomic-primops' 'haskell-primitive')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('2b4e23cbb0706dbcf4aeb820901b4b1c357a136472ff065c42dd58f6cfbb3c8e87b5503fe285b9c3a557791f959b82091138e8e137b88496fb92d2562506a3a3')
19 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22 runhaskell Setup build $MAKEFLAGS
23 runhaskell Setup register --gen-script
24 runhaskell Setup unregister --gen-script
25 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
31 # https://github.com/jberryman/unagi-chan/issues/25
32 runhaskell Setup test || :
38 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
39 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
40 runhaskell Setup copy --destdir="$pkgdir"
41 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
42 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE