upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-validity / trunk / PKGBUILD
blob9ef5c69a80800dbf262f0255cac716cb2ff7ca24
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=validity
4 pkgname=haskell-validity
5 pkgver=0.12.0.1
6 pkgrel=39
7 pkgdesc="Validity typeclass"
8 url="https://github.com/NorfairKing/validity"
9 license=('MIT')
10 arch=('x86_64')
11 depends=('ghc-libs')
12 makedepends=('ghc' 'uusi' 'haskell-hspec')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('15d200317bfb71605e210528be5eba70383d8667873771d4391bca97c8e6d146333787e471877b167bae57adc55fc0e0276b6082a9bb7b5dc48f5d714cef5fbe')
16 prepare() {
17     cd $_hkgname-$pkgver
18     gen-setup
21 build() {
22     cd $_hkgname-$pkgver
24     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
27     runhaskell Setup build $MAKEFLAGS
28     runhaskell Setup register --gen-script
29     runhaskell Setup unregister --gen-script
30     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
34 check() {
35     cd $_hkgname-$pkgver
36     runhaskell Setup test --show-details=direct
39 package() {
40     cd $_hkgname-$pkgver
42     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44     runhaskell Setup copy --destdir="$pkgdir"
45     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
46     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE