upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-warp-tls / trunk / PKGBUILD
blobe710860d299e965fc5940f126fc60c03995c921f
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=warp-tls
5 pkgname=haskell-warp-tls
6 pkgver=3.3.6
7 pkgrel=11
8 pkgdesc="HTTP over TLS support for Warp via the TLS package"
9 url="https://github.com/yesodweb/wai"
10 license=("MIT")
11 arch=('x86_64')
12 depends=('ghc-libs' "haskell-cryptonite" "haskell-data-default-class" "haskell-network" "haskell-recv"
13          "haskell-streaming-commons" "haskell-tls" "haskell-tls-session-manager" "haskell-unliftio"
14          "haskell-wai" "haskell-warp")
15 makedepends=('ghc')
16 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
17 sha512sums=('43cfa73a38259505b469fbd1c356df19bba392893c142dec463aa663798869d78c3057f79c3751c3c80e38cb30f6593d1e1fef50eb5969f40fa294de8107c0a5')
19 build() {
20     cd $_hkgname-$pkgver
21     
22     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
23         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
24         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
25     runhaskell Setup build $MAKEFLAGS
26     runhaskell Setup register --gen-script
27     runhaskell Setup unregister --gen-script
28     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 check() {
33     cd $_hkgname-$pkgver
34     runhaskell Setup test --show-details=direct
37 package() {
38     cd $_hkgname-$pkgver
39     
40     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
41     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
42     runhaskell Setup copy --destdir="$pkgdir"
43     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
44     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE