upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / haskell-wuss / trunk / PKGBUILD
blob3666c839bf80a2c5039bd9e092399fc07e49b6f0
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=wuss
4 pkgname=haskell-wuss
5 pkgver=2.0.1.1
6 pkgrel=7
7 pkgdesc="Secure WebSocket (WSS) clients"
8 url="https://github.com/tfausak/wuss"
9 license=("MIT")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-connection' 'haskell-network' 'haskell-websockets')
12 makedepends=('ghc' 'uusi')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('2023b7147a08734cb696011306be130d24ecc3a6ac8a4c526dbb37f38309b255')
16 prepare() {
17   cd $_hkgname-$pkgver
18   gen-setup
21 build() {
22   cd $_hkgname-$pkgver
24   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
27     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
28     --ghc-option='-pie' \
29     -f-pedantic
31   runhaskell Setup build $MAKEFLAGS
32   runhaskell Setup register --gen-script
33   runhaskell Setup unregister --gen-script
34   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
35   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
38 check() {
39   cd $_hkgname-$pkgver
40   runhaskell Setup test --show-details=direct
43 package() {
44   cd $_hkgname-$pkgver
46   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
47   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
48   runhaskell Setup copy --destdir="$pkgdir"
49   install -D -m644 LICENSE.markdown -t "$pkgdir"/usr/share/licenses/$pkgname/
50   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE.markdown