1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Alireza Ayinmehr <alireza.darksun@gmail.com>
3 # Contributor: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
4 # Contributor: JSkier <jskier at gmail dot com>
5 # Contributor: Ivan Shapovalov <intelfx@intelfx.name>
10 pkgdesc='High-performance regular expression matching library'
12 url=https://www.hyperscan.io
23 _tag=bc3b191ab56055e8560c7cdc161c289c4d76e3d2
24 source=(git+https://github.com/intel/hyperscan.git#tag=${_tag})
29 git describe --tags | sed 's/^v//'
33 cmake -S hyperscan -B build -G Ninja \
34 -DCMAKE_INSTALL_PREFIX=/usr \
35 -DCMAKE_INSTALL_LIBDIR=lib \
36 -DBUILD_SHARED_LIBS=ON \
42 DESTDIR="${pkgdir}" cmake --install build
43 install -Dm 644 hyperscan/COPYING -t "${pkgdir}"/usr/share/licenses/hyperscan/