upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / hyphen-it / repos / community-any / PKGBUILD
blob89ed61590854053cb7f31c4124a83f0feec1cb64
1 # Maintainer: Andrea Scarpino <andrea@archlinux.org>
3 pkgname=hyphen-it
4 pkgver=20071127
5 pkgrel=6
6 pkgdesc="Italian hyphenation rules"
7 arch=('any')
8 url="http://wiki.services.openoffice.org/wiki/Dictionaries"
9 license=('LGPL')
10 optdepends=('hyphen: offers hyphenation library functions')
11 source=("http://openoffice.cs.utah.edu/contrib/dictionaries/hyph_it_IT.zip")
12 md5sums=('ee57402fa3930e0641d627ec7f4f1619')
13 sha256sums=('3e7961e7b1bc13e0c6f13826fccb415ceb37bbc68a2a83739db2b7a442a6e197')
15 package() {
16   install -d "${pkgdir}"/usr/share/hyphen
18   install -m644 hyph_it_IT.dic "${pkgdir}"/usr/share/hyphen/hyph_it_IT.dic
20   pushd "${pkgdir}"/usr/share/hyphen/
21   it_IT_aliases="it_CH la_VA"
22   for lang in $it_IT_aliases; do
23     ln -s hyph_it_IT.dic hyph_$lang.dic
24   done
25   popd
27   # the symlinks
28   install -d "${pkgdir}"/usr/share/myspell/dicts
29   pushd "${pkgdir}"/usr/share/myspell/dicts
30     for file in "${pkgdir}"/usr/share/hyphen/*; do
31       ln -sv /usr/share/hyphen/$(basename $file) .
32     done
33   popd