upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / imapsync / trunk / PKGBUILD
blob79ddc19f7ebc687ddd7a9c4d2b6d9331be5e1f00
1 # Maintainer: Frederik Schwan <freswa at archlinux dot org>
3 pkgname=imapsync
4 pkgver=2.229
5 pkgrel=1
6 pkgdesc='IMAP synchronisation, sync, copy or migration tool'
7 arch=('any')
8 url='https://github.com/imapsync/imapsync'
9 license=('custom:imapsync')
10 depends=(perl-{cgi,crypt-openssl-rsa,data-uniqid,date-manip,encode-imaputf7,file-copy-recursive}
11   perl-{file-tail,html-parser,io-socket-inet6,io-socket-ssl,io-tee,json-webtoken,libwww}
12   perl-{module-scandeps,mail-imapclient,module-runtime,ntlm,package-stash,proc-processtable}
13   perl-{readonly,regexp-common,sys-meminfo,term-readkey,unicode-string}
15 makedepends=(cpanminus perl-par-packer)
16 checkdepends=(inetutils lsb-release time procps-ng
17   perl-{test-deep,test-fatal,test-mock-guard,test-mockobject,test-pod,test-requires,test-warn}
19 source=("https://github.com/imapsync/imapsync/archive/refs/tags/${pkgname}-${pkgver}.tar.gz")
20 b2sums=('1fbb52e014e18ed8970e56031b64aa3429d6383bc71b0d47e08528b300dfda4591ba279e6c752bdf3a609ae6873bddb61cdcc8ead53750112fc1969e101e1a99')
22 build() {
23   make -C ${pkgname}-${pkgname}-${pkgver}
26 check() {
27   make -C ${pkgname}-${pkgname}-${pkgver} test
30 package() {
31   cd ${pkgname}-${pkgname}-${pkgver}
32   make DESTDIR="${pkgdir}" install
33   install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.txt