upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / indicator-china-weather / trunk / PKGBUILD
blob09df8d4816a85a66013cf0d1fe42dab053ed2403
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=indicator-china-weather
4 pkgver=3.0.4
5 pkgrel=1
6 pkgdesc="Indicator that displays China weather information"
7 arch=('x86_64')
8 license=('GPL')
9 url="https://github.com/UbuntuKylin/indicator-china-weather"
10 groups=('ukui')
11 depends=('geoip' 'qt5-base')
12 makedepends=('qt5-tools')
13 source=("https://github.com/UbuntuKylin/indicator-china-weather/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
14 sha512sums=('79f3944591e6d1988b745e9567d9a3ef023a53d435b5164376d7295c4419edc75fb62a8c970552ea34fe66d1b13ff263d5948e9a6f418a6d3a596a88f85c4501')
16 prepare() {
17   cd indicator-china-weather-$pkgver
18   sed -i '/#include <QPainter>/a #include <QPainterPath>' src/{tooltip,cityitemwidget,texttip}.cpp
19   sed -i '/dpkg-buildflags/d' indicator-china-weather.pro
22 build() {
23   cd indicator-china-weather-$pkgver
24   qmake-qt5 PREFIX=/usr
25   make
28 package() {
29   cd indicator-china-weather-$pkgver
30   make INSTALL_ROOT="$pkgdir" install