upgpkg: wordpress 6.2.1-1
[ArchLinux/community.git] / jupyterlab-widgets / trunk / PKGBUILD
blob56a4ccdf341e61db6bfa626c479b07caf9b5dd2c
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 _pipname=jupyterlab_widgets
4 pkgname=${_pipname/_/-}
5 pkgver=3.0.7
6 pkgrel=2
7 pkgdesc='JupyterLab extension to use ipywidgets'
8 arch=(any)
9 url='https://jupyter.org/'
10 license=(custom)
11 depends=(jupyterlab python-ipywidgets)
12 makedepends=(python-build python-installer python-setuptools python-jupyter_packaging)
13 source=(https://pypi.io/packages/source/${_pipname:0:1}/$_pipname/$_pipname-$pkgver.tar.gz)
14 sha256sums=('c3a50ed5bf528a0c7a869096503af54702f86dda1db469aee1c92dc0c01b43ca')
16 build() {
17   cd $_pipname-$pkgver
18   python -m build --wheel --skip-dependency-check --no-isolation
21 package() {
22   cd $_pipname-$pkgver
23   python -m installer --destdir="$pkgdir" dist/*.whl
25   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname